Back to overview
Degraded
Service Outage
Jun 12 at 07:28pm BST
Affected services
Website
API
Resolved
Jun 12 at 09:37pm BST
Incident should be resolved.
Affected services
Updated
Jun 12 at 08:24pm BST
We are continuing to work with our providers to resolve this issue.
Affected services
Updated
Jun 12 at 07:47pm BST
We are continuing to investigate and work with our providers to resolve this issue.
Affected services
Created
Jun 12 at 07:28pm BST
We are currently experiencing a service outage affecting all data-related operations, including file uploads and other data functionalities, due to an issue with our providers.
Affected services