Back to overview
Resolved

Degraded performance in EU West

Jul 30, 2026 at 3:38pm UTC
Affected services
Website
API
Relay
EU West (eu-west-1)

Resolved
Aug 1, 2026 at 10:20am UTC

Incident should be resolved.

Updated
Aug 1, 2026 at 8:16am UTC

We've implemented a fix on our end that have addressed the degraded performance and we are continuing to monitor the recovery.

Created
Jul 30, 2026 at 3:38pm UTC

We are currently experiencing degraded performance affecting upload speeds in the eu-west-1 region due to an issue with our providers. We will provide an update as soon as possible.